MAILBOOK Online User Guide: The MAIL Command

The MAIL Command
When you want to send or receive electronic mail, you will use the MAIL command. You may correspond with users on your computer system and users on any computer system linked with yours through a network. When you receive mail, the system will place it into a holding area until you get a chance to read it.

Screen Basics
Before we go any further, you need to learn a little about how to work with the screen. Every screen you will see while using MAIL looks something like the following:

--------------------------------------------------------------------------------

  Notebook   Message  View  Options  Window  Help
________________________________________________________________________






Work area






________________________________________________________________________
====>
F1 =Help      F2 =Open     F3 =Quit     F4 =Print    F5 =Reply    F6 =Include
F7 =Backward  F8 =Forward  F9 =Delete   F10=MenuBar  F11=Save     F12=Cancel

--------------------------------------------------------------------------------
Figure 6 - Mail Screen Basics

Menu Bar
At the very top of the screen is an area known as the menu bar. The menu bar is used to select actions to be performed by the MAIL command. To select an action, move the cursor to one of the selections on the menu bar and press the Enter key. You can move the cursor either by using the arrow keys, or by pressing F10. Pressing F10 repeatedly will move the cursor to and from the menu bar. Once the cursor is on the menu bar, you can use the arrow keys to move the cursor to your selection, or press Tab to move from one selection to the next. When the cursor is on your selection, press the Enter key.

Pull-Down Menus
Once you have made your selection from the menu bar, a pull-down menu will appear.

--------------------------------------------------------------------------------

   Notebook  Message  View  Options  Window  Help
 ____________________________  _______________________________________________
|   Status                   |   Mail Inbasket             Lines 1 to 16 of 80
|   Print all                |                                      More:    +
|   Copy all                 |  ject:                      Size:
|   Copy all as...           |  l 99                             58
|   Move all                 |  l99 work in progress             62
|   Move all as...           |  l & Mailbook suggestions         30
|   Exit                 F3  |  ail prices                       24
|____________________________|  mpting for index creation        20
Help  Desk           2/05/99*questions about Mail                30
T. O. P. Banana      2/05/99*multiple notebooks open             22
John                 2/07/99*Prompting for index creation        50
Prince Charming      2/08/99*Is there a way?                     45
Richard Schafer      2/08/99 You're invited to a ball            39
I. M. Dozing         2/09/99 Agenda for Monday 2/15/99           50
Scott Nealy          2/10/99 Yes, I really do like MOTIF         24
Dwarf Council        2/10/99*Agenda for Monday 2/15/99           33
Prince Charming      2/15/99*Glass Slipper????                  773
Nick Gimbrone        2/15/99 Enhancement request                 22
Prince Charming      2/16/99 Future plans                       153
_______________________________________________________________________________
====>
F1 =Help     F2 =Open     F3 =Quit     F4 =Print    F5 =Reply    F6 =Include
F7 =Backward F8 =Forward  F9 =Delete   F10=MenuBar  F11=Save     F12=Cancel

--------------------------------------------------------------------------------
Figure 7 - Pull-down Menus

To select a choice on the pull-down menu, move the cursor either with the arrow keys or the Tab key to the desired choice and press Enter. Some choices may be labeled with a function key, indicating that key is a shortcut key. Pressing that function key will select that choice from the menu, even if the pull-down menu is not currently displayed. If you put the cursor somewhere else on the menu bar and press Enter, the original pull-down menu will disappear and a new one corresponding to the new selection will appear.

A choice which ends with “...” indicates that a secondary menu or an action window will appear if that choice is taken, allowing you to further define what action you wish to choose.

Screen Title
Below the menu bar is a separator line, followed by a screen title. In menu mode, the screen title shows Mail inbasket. When reading a message, the screen title will indicate the person who sent the mail. When composing a message, the screen title will be Sending Mail.

Textual Scrolling Location Information
To the right of the title you will see Line n to m of p, which tells you which lines of the file are currently displayed on the screen.

Scrolling Information
Below the location information, you will see More:, followed by -, +, . A - indicates that there is information above the visible area, and a + indicates that there is information below the visible area. You could scroll up or down to see the information not currently visible. The indicators will only appear when the message is wider than the screen. A indicates that there is information to the right of the visible area. You could scroll left or right to see the information not currently visible.

Work Area
Below the scrolling information is the general work area of the screen, extending to all but the last three lines of the screen. The menu display will be in this area, for example.

Message Area
The third line from the bottom of the screen is the message area. Short messages will appear in this area. When no message is in this area, it will be filled with “___”, in order to serve as a bottom border for the work area.

Command Line
commands, or CMS commands in this area for execution.

Function Key Area
The last line on the screen is the function key area. This area describes the first 6 function keys. An option is available to show up to 24 keys on 4 lines.5

Action Windows
From time to time, an action window will appear on the screen. In most cases, you will be instructed to fill in some information and press Enter to process it. Occasionally, you will see buttons at the bottom of the action window, indicating a choice to be made. To make a choice, position the cursor inside one of the buttons and press Enter.

Preparing Mail

To send mail, type

MAIL recipient
and press Enter.

recipient can be one or more nicknames in your NAMES file, userids of people on your computer system, or addresses of users on other computer systems connected to yours by a network. (Look below for a definition of address.)

You must specify a recipient when you want to create mail. If you don't specify a recipient, MAIL will display your incoming mail.

If you're sending mail to someone who has a NAMES file entry, then recipient can be that person's nickname. If you're sending mail to someone at your site who does not have a NAMES file entry, then recipient is that person's userid. If you're sending mail to someone on another computer system who does not have a NAMES file entry, you'll need to specify the recipient's address. An address is merely userid@domain where domain is the name of your recipient's computer system.

For example,

MAIL SLEEPY
or,

MAIL FNORD@Bavarian.Illuminati.Org
MAIL sends your outgoing mail to an address built from your recipient's userid and domain. Unless it's specified, MAIL assumes that your recipient's domain is the same as yours.

If you are sending mail to someone on your computer system, MAIL will verify your recipient's userid. If the userid is not valid, MAIL will give you another chance to supply a valid recipient or to drop out of MAIL if that was your only recipient.

--------------------------------------------------------------------------------

  Enter=Forward F7 =Backward F8 =Forward F12=Cancel         Columns 1 - 79 of 81















   ____________________________________________________________________________
  |                             Unknown local user                             |
  |                                                                            |
  |   User WhoMe? is undefined.                                                |
  |  Enter replacement:                                                        |
  |  _________________________________________________________________         |
  |                                                                            |
  | F1 =Help  F12=Cancel                                                       |
  |____________________________________________________________________________|






  PF1=Help      2=Pop_Msg   3=Quit       4=Clear_Top  5=Filelist   6=Retrieve
  PF7=Backward  8=Forward   9=Rdrlist   10=Left      11=Right     12=Clear
  ====>
 17:08:17                                   Enter your response in vscreen MAIL

--------------------------------------------------------------------------------
Figure 8 - Asking for a replacement recipient

If your recipient doesn't have a NAMES file entry or the Name field on the entry is blank, MAIL will ask you for a name as shown below.

This might be your recipient's full name. If you do not wish to enter a name, just press Enter and MAIL will use your recipient's electronic address. From then on, MAIL won't bother you for any other names it does not know.6

--------------------------------------------------------------------------------

Enter=Forward F7 =Backward F8 =Forward F12=Cancel         Columns 1 - 79 of 81




   ____________________________________________________________________________
  |                                  Optional                                  |
  |                                                                            |
  |  Name for someuser@yourdomain                                              |
  |  ___________________________________________________________________       |
  |                                                                            |
  | F1 =Help  F12=Cancel                                                       |
  |____________________________________________________________________________|


















  PF1=Help      2=Pop_Msg   3=Quit       4=Clear_Top  5=Filelist   6=Retrieve
  PF7=Backward  8=Forward   9=Rdrlist   10=Left      11=Right     12=Clear
  ====>
 17:12:24                                   Enter your response in vscreen MAIL

--------------------------------------------------------------------------------
Figure 9 - Asking for recipient 's name

Now the screen shown below will appear. You are being asked to enter the subject of your mail item. If you don't choose to enter a subject, simply press Enter.

--------------------------------------------------------------------------------

  Enter=Forward F7 =Backward F8 =Forward F12=Cancel         Columns 1 - 79 of 81














   __________________________________________________________________
  |                             Optional                             |
  |                                                                  |
  |  Enter subject:                                                  |
  |  _________________________________________________________       |
  |                                                                  |
  | F1 =Help  F12=Cancel                                             |
  |__________________________________________________________________|








  PF1=Help      2=Pop_Msg   3=Quit       4=Clear_Top  5=Filelist   6=Retrieve
  PF7=Backward  8=Forward   9=Rdrlist   10=Left      11=Right     12=Clear
  ====>
 17:16:11                                   Enter your response in vscreen MAIL

--------------------------------------------------------------------------------
Figure 10 - Asking for a subject for the message

Typing the Body of the Mail

The MAIL screen will appear on your terminal as shown in Figure 11. You are in edit mode, just as though you are XEDITing a file, although you do not necessarily need to know anything about XEDIT. Information on XEDIT is available at your Help Desk.7

When the MAIL screen appears, the cursor is positioned in the input area (the area below the line of equal signs) and you can begin typing the body of your mail. You can type anywhere in the input area. The area above the equal signs is known as the header, and contains addressing information. If you wish to add a line between two lines, position the cursor on the first of the two lines and press F2. A blank line will appear between the two lines. If you fill the screen and wish to add more lines, you can press F4 and a page of blank lines will be added at the end of your mail.

--------------------------------------------------------------------------------

  Message  Edit  Attachments  Options  Window  Help
_______________________________________________________________________________
                                  Sending Mail             Lines 2 to 17 of 18
                                                                  More:   - +
From:         Snow White 
Organization: Beautiful Princesses, Inc.
Subject:      Welcome to the Forest!
To:           "Richard A. Schafer" 
========================================================================














_______________________________________________________________________________
====>
F1 =Help     F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 11 - Starting a new message

Notice how each time you add new lines with either F2 or F4, the screen display scrolls up. By the time you have finished typing your mail the header may have scrolled off the screen). To see your header, simply press F7 to scroll the screen back page by page to the top of your file.

You will notice that the bottom of the entry screen shows a list of function key settings. For example, if your mail doesn't fit on one screen you can press F8 (Forward) to scroll your mail item from one screen to the next. You can also use XEDIT commands that are not assigned to function keys as you would when XEDITing any file.

If you want to use character insert mode, just press the insert mode key, insert your characters or words, and press the RESET key to resume normal typing.

Including an Existing File

You can include the text of an existing file in your mail in one of two ways.

You can enter the MAIL name command like this:

MAIL name (FILE filename filetype filemode where filename, filetype, and filemode identify the file you want to include.

For example, when Snow White sends a copy of her autobiography, The Snow Was White, which she keeps online in file SNOWHITE AUTOBIO A, to her publisher, Vanity Books, she enters

MAIL VANITY (FILE SNOWHITE AUTOBIO A The text of SNOWHITE AUTOBIO appears on her screen as show below. The cursor is positioned on the command line. The mail item is available for editing using XEDIT commands as discussed above.

--------------------------------------------------------------------------------

Message  Edit  Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 3 to 19 of 19
                                                                        More: -
From:         Snow White 
Organization: Beautiful Princesses, Inc.
Subject:      A Wonderful Life
To:           Bennet Smurf 
========================================================================
Once upon a time....


I scrub therefore I am....




but I'm tired.............






_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 12 - Typing the message text

If you are already in the mail screen when you decide to include an existing file, press Enter to move your cursor to the command line. Use the XEDIT UP n and DOWN n commands to position the current line (which will be highlighted) so that it is the line that you want the included text to follow. Then press F10 to move the cursor to the menu bar, and choose Include File from the Edit menu. An action window will appear allowing you to specify the file that you want to include. You can press F4 to get a list of files to select from if you can not remember the exact name of the file. After selecting the file, press Enter one more time. The text of the included file will be added after the current line.

Editing the Mail Header

The mail header is created for you by MAIL and appears at the top of a mail item. It shows the date and time the mail is created and identifies the sender and recipients of the mail.

You might create mail and then want to change the list of recipients. To add recipients to the list, select Add Recipient from the Edit menu. An action window will appear, allowing you to enter one or more people to be added.

To delete recipients from the list, select Delete Recipient from the Edit menu. An action window will appear listing the names (or address, if no name was provided) of the current list of recipients. Select the one you want to exclude by positioning the cursor on it and then pressing the Enter key.8

--------------------------------------------------------------------------------

  Message  Edit  Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 3 to 19 of 19
                                                                       More: -
From:         Snow White 
Organization: Beautiful Princesses, Inc.
Subject:      A Wonderful Life
To:           Bennet Smurf 
              "S. A. What" 
========================================================================
Once upon a time....


I scrub therefore I am....




but I'm tired.............






_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 13 - Adding a recipient

For example, Show White could decide that she wants to send her autobiography to Dopey as well as to her publishers. She would press F10 to move her cursor to the menu bar, select Edit then Add Recipient as described above, then enter DOPEY in the window and press Enter. Her new header appears as shown above.

If she changes her mind again, to remove Dopey, she would press F10 to move her cursor to the menu bar, select Edit, then Delete Recipient as described above, then position the cursor on the line which reads

S. A. What
and press the Enter key.

Saving Your Outgoing Mail
A copy of your outgoing mail is automatically saved (stored) for you when you SEND the mail.9 You'll find the copy in file name NOTEBOOK where name is the Notebook name listed in your NAMES file entry for your recipient. If you have no NAMES file entry for a recipient or no Notebook name in the entry, your mail is saved in file ALL NOTEBOOK.

When you send your mail to many recipients, a copy of the mail is saved into each recipient's notebook. If you've assigned the same notebook to more than one recipient only one copy of your mail is saved in that notebook. If you haven't assigned a notebook to more than one recipient, only one copy of your mail is saved into ALL NOTEBOOK.

You may prefer to take charge of saving your outgoing mail. To save a mail item in the notebook of your choice (and override MAIL's choice), select Save As from the Message menu. An action window will be displayed showing the default notebook. You may type over the default name to change it. If the name you type matches more than one file, when you press the Enter key, you'll see another action window listing files which match your pattern. Position the cursor on one of them and press Enter to select it. A message will appear at the bottom of your screen saying “This mail will be saved in filename NOTEBOOK A0 when it is sent.” This message lets you know that your mail will be saved when you send it. To clear the message from the screen simply press Enter.

Continuing MAIL At A Later Time
Sometimes you may find it necessary to leave a piece of mail before you finish it. With electronic mail, you don't have to lose the work you've done. You can save your mail by pressing F12. An action window will appear giving you three choices. Put the cursor in the Suspend button and press Enter. Your mail will be saved in file userid MAIL A where userid is the userid of your first recipient. You can specify a different filename by selecting Suspend from the Message menu. An action window will appear allowing you to specify a filename to use for saving your work. Then your mail will be saved in filename MAIL A.

When you are ready to continue working on your mail, enter the MAIL command with the RESUME option as follows:

MAIL filename (RESUME
where filename is the name you chose or allowed to default. If filename is a userid, you may specify the appropriate nickname instead. Your mail will appear on your screen for additional input, exactly as you left it.

Sending Mail
When you are finished typing your mail you can send your mail by selecting Send from the Message menu. An action window will appear asking if you are ready to send your mail. If you are ready to send it, position the cursor in the Send button, and press Enter. If you want to return to composing your mail, position the cursor in the Cancel button and press Enter.

Changing your Mind
If you have started a mail item and decide that you do not want to send it, press F12 and an action window will appear. Position the cursor in the Discard button, and press Enter. Your mail item will be erased.

Sending Mail to People on a List
The nickname you specify on the MAIL command can be the nickname of a list in your NAMES file. In this case, your mail will be sent to each person in the list.

--------------------------------------------------------------------------------

Message  Edit Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 3 to 19 of 19
                                                                        More: -
From:         Snow White 
Organization: Beautiful Princesses, Inc.
Subject:      While I'm gone
To:           "I. M. Dozing" ,
              "S. A. What" ,
              "T. O. P. Banana" ,
              "H. A. Haas" ,
              "E. B. Scrooge" ,
              "A. H. Choo" ,
              "R. U. Shy" ,
              JOHN@Forest.tx.us
========================================================================
This is to introduce JOHN who'll be taking my place shortly.


He's an experienced poison fruit tester and maintenance dwarf.


JOHN, meet the guys.


_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 14 - Sending mail to a list of people

For example, Snow White's NAMES file contains an entry whose nickname is DWARFS as shown in Figure 5. The field titled List of Names in that entry lists the nicknames of the seven dwarfs. It also lists the userid JOHN. The command

MAIL DWARFS
sends a copy of Snow White's mail to each of the seven dwarfs and one user JOHN. Remember that JOHN does not have an entry in Snow White's NAMES file. Since Snow White did not enter a name for JOHN when MAIL asked for it, MAIL placed his userid and the local domain in the address list.

Sending Complimentary Copies
You may want to send someone a copy of a mail item you are addressing to someone else. This is called a complimentary copy. For example, if Snow White wants to send mail to Evil Queen and have I. M. Dozing and E. B. Scrooge each receive a copy, she would enter the MAIL command like this:

MAIL QUEEN CC: GRUMPY SLEEPY

--------------------------------------------------------------------------------

  Message  Edit Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 3 to 19 of 19
                                                                       More: -
From:         Snow White 
Organization: Beautiful Princesses, Inc.
Subject:      Nah-Nah!
To:           Evil Queen 
cc:           "E.B. Scrooge" ,
              "I. M. Dozing" 
========================================================================
You'll never find me.










but I'm tired..............










_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 15 - Sending complimentary copies

CC stands for complimentary copy. The name(s) following CC: can be one or more nicknames from your NAMES file, userids of users on your computer system, and/or addresses of users on other computer systems linked to yours through a network.

As shown below, QUEEN is the main recipient of Snow White's mail. GRUMPY and SLEEPY are nicknames of dwarfs who have entries in Snow White's NAMES file. The mail header shows that they are complimentary copy recipients.

The name following CC: can also be the nickname of a list.

For example,

MAIL DOC CC: DWARFS
DWARFS is the nickname of an entry (see Figure 5.) that contains a list of names. Each dwarf in the list and JOHN will receive a complimentary copy.

What if you create mail and then want to change the complimentary copy recipient(s)? You may add or delete recipients to the list, just like you learned how to add or delete recipients in the main list. See the earlier section, Editing the Mail Header, for examples of adding and deleting recipients.

Requesting an Acknowledgement
If you want to know when mail you send is read, you can request that an acknowledgement be sent to you when each of your recipients first reads your mail.

In the example above, if you want to know when DOC and each of the recipients in the list DWARFS reads your mail for the first time, enter

MAIL DOC CC: DWARFS (ACK
Each time one of the dwarfs first reads your mail, you'll be sent mail in return. When DOC reads your mail, your menu screen will look like Figure 16 and the actual acknowledgement like Figure 17.

Warning: Because there is no network-wide standard for how to request acknowledgement, you will only receive acknowledgement from people using MailBook to read their mail.

Commands for Preparing and Sending Mail
In addition to the pull-down menu forms that have been described so far, there are subcommands of Mail that can be used to do most things. To enter one of the following subcommands, press Enter to move the cursor to the command line, then enter the appropriate subcommand.

First issue the MAIL command, by typing

Command Effect
MAIL name1 Send mail to name1 where name is a nickname, a userid, an address, or the nickname of a list of names
MAIL name1 name2 name3 Send mail to name1, name2, and name3
MAIL name1 CC: name2 Send mail to name1 with a complimentary copies to name2
MAIL name1 (ACK Send mail to name1, requesting an acknowledgement when name1 reads your mail for the first time
MAIL name1 (FILE fn ft fm Send mail to name1, including the file identified by fn ft fm

After you issue a MAIL command, type your message.

Here is how to temporarily suspend your work and resume it later:

Command Effect
SUSPEND Suspend your work on a mail item
MAIL name1 (RESUME Resume your work on a mail item. "name1" is the userid of the first person in the address list
SUSPEND filename Suspend your work on a mail item, specifying where you want to store the suspended mail item
MAIL filename (RESUME Resume your work on a suspended mail item where you specified a filename

MAIL saves a copy of your mail in each recipient's notebook when you send the mail. If a recipient has no NAMES file entry or no notebook specified in the entry, MAIL uses ALL NOTEBOOK. To override automatic saving, you can enter:

NOLOG To turn off saving of outgoing mail
LOG filename To save mail in filename NOTEBOOK

When you've finished typing your mail, send it by pressing F5 or by pressing Enter to move your cursor to the arrow, typing SEND and pressing Enter. You will be asked to confirm this action.

If you change your mind you can destroy your mail by pressing Enter to move your cursor to the arrow, typing QQUIT and pressing Enter.

Reading Incoming MAIL
To read any mail you have received, just type

MAIL
on the CMS command line and press Enter.

The MAIL MENU screen will appear as shown in Figure 16 on Page 24. The menu will include not only new incoming mail, but also old incoming mail that you left in your mailbox. If there isn't any incoming mail (either old or new), MAIL will say No incoming mail.

The MAIL MENU screen displays information about the mail that you have received. The person who sent the mail to you, the date sent, the subject of the mail, and the size of the mail are displayed on the menu screen. If the date is preceded by a >, then you have not yet read this mail item. If the subject has an * preceding it, the mail is a response to mail you (or someone else) sent. If the subject begins Ack: Mail of ..., the mail is an acknowledgement of receipt of mail you sent. (Please see the section Requesting an Acknowledgement above.)

--------------------------------------------------------------------------------

  Notebook  Message  View  Options  Window  Help
_______________________________________________________________________________
                                  Mail Inbasket            Lines 39 to 53 of 53

                                                                       More: -
From:                 Date:  Subject:                      Size:
T. O. P. Banana      3/19/99*Forest ecology                      30
I. M. Dozing       > 3/19/99 Ack: Mail of 5/29 16:44:53          17
Richard Schafer    > 3/19/99*domains in BITNET                   47
Mr. Mail             3/19/99 Domains                             11
schafer@is         > 3/19/99 No subject                          59
CCITT@GENEVA         3/20/99 ISOOSI and X.400                    27
Nick Gimbrone        3/20/99*Why I love PROFS - NOT!             27
E. B. Scrooge        3/20/99 phone-Apple dealer                  12
Ive Ben-Had        > 3/20/99 PROFS vs. OfficeVision             233
Prince Charming      3/20/99 Internet library resources          62
Sara L. Goodman      3/20/99 Wish I were there                   16
Prince Charming    > 3/20/99*Glass Slipper????                   32
* * * End of File * * *
_______________________________________________________________________________
====>
F1 =Help     F2 =Open     F3 =Quit     F4 =Print    F5 =Reply    F6 =Include
F7 =Backward F8 =Forward  F9 =Delete   F10=MenuBar  F11=Save     F12=Cancel

--------------------------------------------------------------------------------
Figure 16 - The MAIL menu screen

Use the READ command to read the mail on the MAIL MENU screen. To read a specific mail item, place your cursor anywhere on the line describing the mail and press F2. The mail will be displayed for you as shown in Figure 18.

--------------------------------------------------------------------------------

Message  Edit  Send  Options  Window  Help
_______________________________________________________________________________
                          Mail from: T. O. P. Banana      Lines 5 to 10 of 10


Date:    Fri, 20 Mar 1999 18:42:50 CST
From:    DOC@Forest.tx.us
To:      SNOWHITE@Forest.tx.us
Subject: Ack: Mail of Fri, 20 Mar 1999 18:42:26 CST


Ack:   Received mail you sent on Fri, 20 Mar 1999 18:42:26 CST
* * * End of File * * *




















_______________________________________________________________________________
====>
F1 =Help      F2 =Open     F3 =Quit     F4 =Print    F5 =Reply    F6 =Include
F7 =Backward  F8 =Forward  F9 =Delete   F10=MenuBar  F11=Save     F12=Cancel

--------------------------------------------------------------------------------
Figure 17 – Receiving an acknowledgement

--------------------------------------------------------------------------------

  Message  Edit  Send  Options  Window  Help
________________________________________________________________________________
 Message 6 of 18              Mail from: Prince Charming     Lines 5 to 24 of 53
                                                                     More:   +
Date:         Fri, 20 Mar 1999 15:39:27 PST
From:         Prince Charming 
Subject:      Re: pine: what it is and how to get it
To:           Snow White 


Snow, we're seriously short of room at the castle.  Do you have any spare space
for storing poisoned apples at your cottage?


I've included below a chart showing how much space we'll need this year
_______________________________________________________________________________
====>
F1 =Help      F2 =Next     F3 =Quit     F4 =Print    F5 =Reply    F6 =Switch
F7 =Backward  F8 =Forward  F9 =Delete   F10=MenuBar  F11=Save     F12=Cancel

--------------------------------------------------------------------------------
Figure 18 - Reading a piece of mail

To read all your incoming mail in sequence, simply press F2. The first mail item will appear. When you have finished reading it, press F2 again and the next mail item will appear. When there is no more mail, the MAIL MENU screen will reappear.

Time Slicing the MAIL MENU display
When you have a great deal of incoming mail to read, you may choose to limit your MAIL MENU display by date.

To do this, select Include... from the View menu. You'll see an action window where you can enter several ways in which you can limit the menu display. You can choose among the following ways of limiting the view:

After - only items sent after a date you specify
Before - only items sent before a date you specify
On - only items sent on a date you specify
Unread only - only items you have never read if Yes
Specific value - only items with a specific value in a specified field

Fill in the blanks with your selection criteria, and press Enter. Only the selected items will remain on the screen and be available for processing.

For example, to time slice the incoming MAIL MENU screen in Figure 16 so that it shows only the mail that was sent on March 20, 1999, you would fill in 3/20/99 on the line reading On date. The resulting MAIL MENU screen is shown in Figure 19 and only the items displayed are available for processing.

--------------------------------------------------------------------------------

   Notebook   Message  View  Options  Window  Help
_______________________________________________________________________________
                                  Mail Inbasket            Lines 44 to 55 of 55


From:                 Date:  Subject:                      Size:
CCITT@GENEVA         3/20/99 ISOOSI and X.400                    27
Nick Gimbrone        3/20/99*Why I love PROFS - NOT!             27
E. B. Scrooge        3/20/99 phone-Apple dealer                  12

Ive Ben-Had        > 3/20/99 PROFS vs. OfficeVision             233
Prince Charming      3/20/99 Internet library resources          62
Sara L. Goodman      3/20/99 Wish I were there                   16
Prince Charming    > 3/20/99*Glass Slipper????                   32
* * * End of File  * * *







_______________________________________________________________________________
====>
F1 =Help      F2 =Open     F3 =Quit     F4 =Print    F5 =Reply    F6 =Include
F7 =Backward  F8 =Forward  F9 =Delete   F10=MenuBar  F11=Save     F12=Cancel

--------------------------------------------------------------------------------
Figure 19 - Limiting the menu to a date range

Saving Incoming Mail
When you have read a mail item, you can choose to save it in a notebook. You save it from the READ MAIL screen shown in Figure 18. Select Save from the Message menu. Your mail will be saved in a notebook called name NOTEBOOK where name is the Notebook name you specified in your NAMES file for the person who sent you this mail. If this person has no entry in your NAMES file or no Notebook value in the entry, then the mail will be saved in file ALL NOTEBOOK.

A message will appear at the bottom of your screen saying “Mail saved in name NOTEBOOK A0”. This message tells you where your mail is saved. To clear the message from the screen simply press Enter.

To save your mail in the notebook of your choice, choose the Save As... entry on the Message menu. You will see an action window with the proposed name for the file. You can accept that name by pressing Enter, or choose another name. Your mail will be saved in file in the file you choose. A message will appear at the bottom of your screen saying “Mail saved in filename NOTEBOOK A0”. This message lets you know that the mail was stored in the file you specified. To clear the message from the screen simply press Enter.

Replying To Mail
Sometimes you receive mail that requires a reply. MAIL makes this easy to do.

If you're in the READ MAIL screen, just press F5.

--------------------------------------------------------------------------------

Message  Edit Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 3 to 20 of 20
                                                                       More: -
From:         Snow White 
Subject:      Re: Running out of storage
To:           Prince Charming 
In-Reply-To:  
========================================================================
We'll have some room just as soon as we clean out the Three Bears' junk.




















_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 20 - Starting a reply

Perhaps you've finished reading your mail and have returned to the incoming MAIL MENU screen. If you decide now to reply to a mail item, just move the cursor to the line describing the mail item and press F5.

A new Send screen will appear as shown in Figure 20. Take a look at the header that MAIL built for you at the top of the screen. Notice that the subject line references the subject of the original mail item. Also notice the new line which reads

In-Reply-To: MAIL has automatically tagged your reply with information that identifies the original mail item.

When this screen is displayed, the cursor is positioned in the input area of the MAIL screen so you can immediately start typing your reply.

Sometimes you want to send a reply to the originator of the mail and to each of the original recipients. If you're in the READ MAIL screen, press Enter to move your cursor to the arrow, type

REPLY ALL
and press Enter. If you're in the incoming MAIL MENU screen, just press Enter to move your cursor to the arrow, type

REPLY ALL
then reposition your cursor to the line describing the mail item and press Enter. A new MAIL screen will appear and you can start typing your reply.

You can also choose to send a reply that includes the original message. If you're in the READ MAIL screen, press Enter to move your cursor to the arrow, type

REPLY TEXT
and press Enter. If you're in the incoming MAIL MENU screen, just press Enter to move your cursor to the arrow, type

REPLY TEXT

--------------------------------------------------------------------------------

Message  Edit Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 3 to 19 of 22
                                                                      More: - +
From:         Snow White 
Subject:      Re: Running out of storage
To:           Prince Charming 
========================================================================
On Friday, 20 Mar 1999 22:49:08 you said:
>Snow, we're seriously short of room at the castle.  Do you have any
>spare space for storing poisoned apples at your cottage?


We'll have some room just as soon as we clean out the Three Bears' junk.














_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 21 - Including the original in the reply

then reposition your cursor to the line describing the mail item and press Enter.

A new MAIL screen will appear as shown in Figure 21. When this screen is displayed, the cursor is positioned on the first line of the original text. Notice that each line of original text is preceded by a greater than sign, ">", in the first column. Just move your cursor down to a blank line and start typing your reply.

What if you wish to have any possible response by the receiver of your mail message sent to someone besides you? Press Enter to move your cursor to the arrow, type

REPLYTO name
and press Enter. "name" may be one or more nicknames in your NAMES file, userids of people on your computer system, or addresses of users on other computer systems connected to yours by a network. For example, if Snow White wants Prince Charming's reply to her mail sent to Sneezy instead of herself, she would press Enter to move her cursor to the arrow, type

REPLYTO SNEEZY
and press Enter. Sneezy would be specified as the recipient of any replies as shown in shown below.

--------------------------------------------------------------------------------

   Message  Edit Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 3 to 19 of 22
                                                                      More: - +
From:         Snow White 
Subject:      Re: Running out of storage
To:           Prince Charming 
Reply-To:     "A. H. Choo" 
========================================================================
We'll have some room just as soon as we clean out the Three Bears' junk.
















_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 22 - Designating a different person to receive replies

When your reply is ready, you can log it, send it, or change your mind and discard it. See the sections Saving Your Outgoing Mail, Sending Mail, and Changing your Mind above.

Forwarding Mail
If you receive mail from someone and feel that another person could benefit from reading it, you can forward the mail to that person.

If you're in the READ MAIL screen, select Forward from the Send menu.

Perhaps you've finished reading your mail and have returned to the incoming MAIL menu screen. If you decide now to forward a mail item, position the current line on the item you wish to forward, then select New... from the Message menu, then select Forward from the secondary menu.

Now, MAIL will ask you to enter information about the recipients to whom you wish to forward the mail item. (See Sending Mail above for a full description of recipient information.)

--------------------------------------------------------------------------------

   Message  Edit Attachments  Options  Window  Help
_______________________________________________________________________________
                                   Sending Mail             Lines 7 to 19 of 19
                                                                       More: -
Date:         Fri, 20 Mar 1999 10:54:48 CST
From:         Snow White 
Subject:      Extra Information
To:           Prince Charming 
========================================================================
Will this make us a toxic waste dump site?




----------------------------Original message----------------------------
Date:         Fri, 20 Mar 1999 10:54:48 CST
From:         Prince Charming 
Subject:      Extra Information
To:           Snow White 


Snow, the number of poison apples we need to store is 12 gross.
         barbara
* * * End of File  * * *


_______________________________________________________________________________
====>
F1 =Help      F2 =Add Line F3 =Quit     F4 =Add Page F5 =Send     F6 =Switch
F7 =Backward  F8 =Forward  F9 =Del Line F10=MenuBar  F11=SpltJoin F12=Cancel

--------------------------------------------------------------------------------
Figure 23 - Forwarding a message to someone else

What if you don't want to forward the entire mail item? Now's your chance to edit the mail before you send it. Your screen will appear as shown above.10 You can edit the mail just as you do in XEDIT. Notice that there is an open space above the original message. You can enter a short note here to explain why you are forwarding this mail.

When the mail is ready, you can save it, send it, or change your mind and discard it. See the sections Saving Your Outgoing Mail, Sending Mail, and Changing your Mind above.

Resending Mail
There is a second method of forwarding mail, known as resending it. In this method, instead of imbedding the entire original message into the body of the new message, some additional header lines are added to the original message.11 To resend a piece of mail, select Resend from the Send menu. You'll have the same ability to edit the message being resent as with forwarding.

When the mail is ready, you can save it, send it, or change your mind and discard it. See the sections Saving Your Outgoing Mail, Sending Mail, and Changing your Mind above.

Switching Modes
When you are reading mail, you are in read mode. When you are replying to or forwarding mail, you are in send mode. When you are viewing a menu, you are in menu mode. A mode becomes active when you begin its associated activity. For example, when you read a mail item, both read and menu modes are active. When you forward or reply to mail, all three modes are active. To switch activities, or modes, select Window on the menu bar, and choose the mode which you wish to see. When both read and send modes are active, you may also move between them by pressing F6.

This feature is especially useful when you are replying to or forwarding incoming mail. You can switch back and forth between your reply or forwarding text and the original letter.

Printing Mail
You may place a copy of a mail item into your virtual printer. Then, if you have neither spooled nor held your printer, the mail item will be sent to your default printer for printing.

If you're in the READ MAIL screen, just press F4.

Perhaps you've finished reading your mail and have returned to the incoming MAIL MENU screen. If you decide now to print a mail item, just move the cursor to the line describing the mail item and press F4.

A copy of the mail item is now in your virtual printer. Depending on your system, you may need to do something else to actually print the mail. Consult your Help Desk for information.

Copying Groups of Incoming Mail
You can copy all the mail items displayed on your MAIL MENU screen by selecting Notebook on the menu bar, and choosing Copy all from the pull-down menu. All of the items will be saved in their default notebooks. If you wish to copy all of the mail into a specific notebook, choose Copy all as... instead of Copy all and you will be given a chance to specify a notebook into which you want to copy the displayed items. If you chose Copy all as..., then a message will appear at the bottom of your screen saying “n mail item(s) copied to filename NOTEBOOK A0” where n is the number of mail items copied. This message lets you know that the mail was stored in the file you specified. If you chose Copy all, then one message will appear for each notebook into which items were copied. To clear the message from the screen simply press Enter.

Moving Incoming Mail
You can choose to move an incoming mail item into a notebook. Moving a mail item marks that item as deleted on the menu.

Select Message on the menu bar, then choose Save then Delete from the pull-down menu. If you were reading the mail item you just moved, then the next mail item will appear on your screen. If there is no more mail, the MAIL MENU screen will reappear. At the bottom of your screen will be a message saying “Previous mail saved in filename NOTEBOOK A0”. This message lets you know that the mail was moved to the file you specified. To clear the message from the screen simply press Enter. When you next view the MAIL MENU screen you will see that a ­ now precedes the date of the moved mail item as shown in Figure 24.

Perhaps you've finished reading your mail and have returned to the incoming MAIL MENU screen. Position your cursor on the item you wish to move, then select Message on the menu bar, then choose Save then Delete from the pull-down menu. Your mail will be moved to file filename NOTEBOOK. A ­ now precedes the date of the moved mail item. (See Figure 24.) Also, a message will appear at the bottom of your screen saying “Mail saved in filename NOTEBOOK A0”. This message lets you know that the mail was moved to the file you specified. To clear the message from the screen simply press Enter.

You can move all the mail items displayed on your MAIL MENU screen by selecting Notebook from the menu bar, and choosing Move all or Move all as... from the pull-down menu. If you chose Move all, then each mail item will be moved to its default notebook. If you chose Move all as..., then you will be given a chance to specify where you want the entire collection moved. All your mail will be moved to file filename NOTEBOOK. A ­ now precedes the date of each moved mail item. (See Figure 24.) Also, a message will appear at the bottom of your screen saying “n mail item(s) moved to filename NOTEBOOK A0” where n is the number of mail items moved. This message lets you know that the mail was moved to the file you specified. If you chose Move all and mail items were moved to more than one notebook, then a separate message will appear for each notebook into which items were moved. To clear the message from the screen simply press Enter.

Use the methods in sections Changing your Mind and Quitting Mail, following this section, to retain moved mail items in incoming mail.

Discarding Mail
After you have read, saved, copied, forwarded, replied to, and/or printed your mail you should discard it from your incoming mail screen. By discarding mail you keep your mail screen up-to-date so you always know when new mail arrives.

To discard mail from the READ MAIL screen, simply press F9 or press Enter to move your cursor to the arrow, type

DISCARD
and press Enter. The next mail item will appear. If you have no more mail, you will return to the incoming MAIL MENU screen. When you next view the MAIL MENU screen you will see that a ­ now precedes the date of the discarded mail item as shown in Figure 24.

--------------------------------------------------------------------------------

Notebook   Message  View  Options  Window  Help
_______________________________________________________________________________
                                  Mail Inbasket            Lines 39 to 53 of 53
                                                                       More: -
From:                 Date:  Subject:                      Size:
T. O. P. Banana      3/19/99*Forest ecology                      30
I. M. Dozing       - 3/19/99 Ack: Mail of 5/29 16:44:53          17
Richard Schafer    > 3/19/99*domains in BITNET                   47
Mr. Mail             3/19/99 Domains                             11
schafer@is         - 3/19/99 No subject                          59
CCITT@GENEVA         3/20/99 ISOOSI and X.400                    27
Nick Gimbrone        3/20/99*Why I love PROFS - NOT!             27
E. B. Scrooge        3/20/99 phone-Apple dealer                  12
Ive Ben-Had        - 3/20/99 PROFS vs. OfficeVision             233

Prince Charming      3/20/99 Internet library resources          62
Sara L. Goodman      3/20/99 Wish I were there                   16
Prince Charming    > 3/20/99*Glass Slipper????                   32
* * * End of File  * * *






_______________________________________________________________________________
====>
F1 =Help      F2 =Open     F3 =Quit     F4 =Print    F5 =Reply    F6 =Include
F7 =Backward  F8 =Forward  F9 =Delete   F10=MenuBar  F11=Save     F12=Cancel

--------------------------------------------------------------------------------
Figure 24 - The MAIL menu after items have been discarded

To discard mail from your incoming MAIL MENU screen, position the cursor on the line describing the mail item and press F9.

Use the methods in sections Changing your Mind and Quitting Mail below to recover discarded mail items in incoming mail.

Changing Your Mind
When you next view the incoming MAIL MENU screen, you will notice that the mail item you've just discarded or moved is still on the menu. Taking a closer look, you will see that a ­ now precedes the date of the mail item as shown in Figure 24. When you quit your mail session (see Quitting Mail below) your mail item will be physically discarded.

Your mail is marked for deletion instead of being discarded to give you a chance to change your mind. If you decide that you want to keep the mail item after all, just press Enter to move your cursor to the arrow, type

UNDISCARD then reposition your cursor to the line describing the mail item, and press Enter. The ­ that preceded the date will disappear.

Note: Discarding a mail item from the incoming mail screen does not affect the contents of your notebooks. If you have saved or copied the mail item into a notebook you will retain that copy even after you discard the mail item from the incoming mail screen.

You get still another chance to change your mind when you QUIT the mail session (see Quitting Mail at the end of this section). Then, if you have any mail items marked for deletion, you'll be asked to verify that you want to delete them. If you don't, they'll all be retained.

Quitting Mail
You can leave MAIL from the MAIL MENU screen by pressing F3 or by pressing Enter to move your cursor to the arrow, typing

QUIT
and pressing Enter. If you are in the READ MAIL screen, you will need to do this twice: once to get to the MAIL MENU screen, and once to leave MAIL.

If you've DISCARDed mail items, a action window will appear telling you how many mail items will be discarded and giving you the choice of discarding them, retaining them, or returning to the menu for further work. Select the Discard button to discard the mail items, the Save button to change your mind and retain them, or cancel to return to the MAIL MENU screen to review which mail items are marked for deletion.

Commands for Reading Incoming Mail
In addition to the pull-down menu forms that have been described so far, there are subcommands of Mail that can be used to do most things. To enter one of the following subcommands, press Enter to move the cursor to the command line, then enter the appropriate subcommand.

You read your mail by typing

MAIL
The incoming MAIL MENU screen will appear. To read the first mail item, press F2 or press Enter to move your cursor to the arrow, type

READ
and press Enter.

Here is how to use any of the commands listed below. If you're in the READ MAIL screen, just press the appropriate function key. From the incoming MAIL MENU screen, just move the cursor to the line describing the mail item and press the appropriate function key.

Command Function Key Description
LOG F11 Save your mail in name NOTEBOOK where name is taken from the NAMES file entry of your correspondent. If there is no entry or the Notebook name is not specified, the mail is saved in ALL NOTEBOOK.
LOG filename NOTEBOOK F11 Save your mail in filename NOTEBOOK
REPLY F5 Reply to mail
FORWARD F13 Forward mail
SWITCH mode F6 Move between the mail menu, a mail item, and its reply or forwarding text. Use F6 to move between the mail item and its reply or forwarding text
PRINT F4 Print mail
COPY name NOTEBOOK Copy mail to name NOTEBOOK
MOVE name NOTEBOOK Move mail to name NOTEBOOK
DISCARD F9 Discard a mail item. F9 will also Undiscard a discarded item
UNDISCARD Restore a discarded mail item
QUIT F3 Quit the MAIL command (or any one of the MAIL displays)

5 If more than one function key line is displayed, then the command line will be the last line on the screen, and all of the function key lines will be displayed above the command line. This rearrangement is caused by a limitation in XEDIT.

6 If you don't want to enter a name for one person, but want to get a chance to enter names for other people, type a blank in the entry field.

7 For those who are familiar with XEDIT you will observe that the screen has no prefix area or scale. If you want to see them, use the XEDIT SET command to turn them on.

8 For experienced users, the INCLUDE and EXCLUDE subcommands can also be used to add and delete recipients. You may even carefully edit the header lines directly, but this is not recommended because of the risk of creating a header which is not valid, making your mail undeliverable.

9 Automatic saving can be disabled if you wish. See the later section, Creating Your Own Environment, for information about customizing Mail.

10 The example screen has been slightly simplified for the sake of clarity, omitting a number of the header lines that you would actually see on your screen.

11 In earlier versions of MailBook, resending was the only means of forwarding available.